[JAMESII-383] Rename one of the two CSVReader classes Created: 02/Aug/13  Updated: 13/Sep/13  Resolved: 13/Sep/13

Status: Resolved
Project: James II
Component/s: Core
Affects Version/s: None
Fix Version/s: James II 0.9.3
Security Level: public (Visible to EVERYONE.)

Type: Improvement Priority: Minor
Reporter: re027 Assignee: re027
Resolution: Fixed Votes: 1
Labels: naming, refactoring
Remaining Estimate: 0 minutes
Time Spent: Not Specified
Original Estimate: 0 minutes

Attachments: Zip Archive mylyn-context.zip    


There is org.jamesii.core.data.runtime.CSVReader, a specific implementation of javax.sql.RowSetReader, but also the utility class org.jamesii.core.util.misc.CSVReader (by [~sl031], Arne Bittig).

This is quite confusing and not immediately clear.

I would suggest to rename org.jamesii.core.data.runtime.CSVReader to RowSetCSVReader.

Comment by re027 [ 13/Sep/13 ]

As this seems to be fine with everyone, I changed the name of org.jamesii.core.data.runtime.CSVReader to RowSetCSVReader.

Generated at Fri Aug 14 07:22:54 CEST 2020 using JIRA 5.0.7#734-sha1:8ad78a62c71cf08b03545eb446cc3b9bb5ce37ad.